Instalando o compiz fusion no (k)ubuntu Feisty Fawn 7.04 num Acer 5102 com uma ATI Xpress 1100


Ok, atendendo a pedidos, segue o meu novo How-To de como instalar o compiz fusion no (k)ubuntu Feisty Fawn 7.04 num Acer 5102 com uma ATI Xpress 1100 , este artigo não contempla a instalação da driver proprietária da ATI, ja que essa informação você encontra facilmente procurando no google.

Então vamos lá🙂

A primeira coisa a fazer é adicionar o repositório do Trevino, para isso basta editar sua sources.list:

sudo vim /etc/apt/sources.list

e acrescentar a seguinte linha:

deb http://download.tuxfamily.org/3v1deb feisty eyecandy

Agora atualize seu sistema:


sudo apt-get update
sudo apt-get dist-upgrade

Feito isso, podemos passar à parte interessante:


sudo apt-get install compiz-fusion-plugins-* compiz-kde compiz-gnome compizconfig-settings-manager compizconfig-backend-kde libcompizconfig-backend-gconf taskbar-compiz compiz-plugins compiz-settings emerald xserver-xgl

Espere terminar a instalação.

Agora a parte complicada:

Primeiro precisamos criar um script que chamará o Xgl + Beryl quando logarmos usando o kdm/gdm, para tal digite:

sudo kedit /usr/local/bin/startxgl.sh

e cole isto:


#!/bin/sh
Xgl -fullscreen :1 -ac -br -accel glx:pbuffer -accel xv:pbuffer &
sleep 4
export DISPLAY=:1
cookie="$(xauth -i nextract - :0 | cut -d ' ' -f 9)"
xauth -i add :1 . "$cookie"
dbus-launch --auto-syntax --exit-with-session /etc/X11/Xsession startkde

nota: se quiser usar o gnome ao invés do kde mude a chamada startkde por gnome-session, agora salve e feche o programa.

agora digite num terminal:

sudo chmod a+x /usr/local/bin/startxgl.sh

Ok, estamos quase lá, agora vamos criar a sessão de login para que
apareca uma nova entrada chamada de XGl quando for logar pelo kdm/gdm )

sudo mkdir -p /etc/X11/sessions
sudo kedit /etc/X11/sessions/xgl.desktop

e copie isto:


[Desktop Entry]
Encoding=UTF-8
Name=Xgl
Exec=/usr/local/bin/startxgl.sh
Icon=
Type=Application

Agora copie o /etc/X11/sessions/xgl.desktop também para /usr/share/xsessions/

Por fim, siga estas instruções:

Compiz Tips and Tricks

E seja Feliz!

This entry was posted in Uncategorized. Bookmark the permalink.

40 Responses to Instalando o compiz fusion no (k)ubuntu Feisty Fawn 7.04 num Acer 5102 com uma ATI Xpress 1100

  1. Paulo Cesar says:

    Detalhe né, para que isso funcione você deve estar usando o driver open source que vem com o Ubuntu.

    Caso esteja usando o driver binário da ATI, o fglrx, saiba que o mesmo não suporta a extensão composite, logo não é possível usar o compiz fusion, a não ser que instale o Xgl.

  2. padoca says:

    Eu aviso no início do artigo, que a driver proprietária tem de estar funcional e com suporte a 3D, o que acarreta que o composite tem de estar desativado.

    Mas você tem razão, esqueci de mencionar o Xgl (já uso desktop 3d a tanto tempo que até esqueço que o Xgl esta lá, pelo menos até a ATI se dignar a lançar a driver com suporte a AiGLX (lá pro fim do ano)).

    Atualizei o artigo para acrescentar o Xgl. Obrigado pela dica🙂

  3. Paulo Cesar says:

    Cara, eu instalei o fglrx para poder rodar uns joguinhos, abdicando do aiglx. Faz muito tempo que não uso o Xgl, então o que você me diz da estabilidade e performace do sistema?

    Dá para assistir vídeos, rodar jogos OpenGL e aplicativos Java sem problemas agora? Ou ainda tem aqueles bugzinhos chatos que me obrigavam a fazer scripts que reiniciavam o X sem o Xgl só para assistir filme?😛

  4. padoca says:

    Bom, se vc tem uma ati xpress 1100 como eu, a sua única opção atualmente é usar o fglrx para ter aceleração 3D já que a driver open source não tem suporte a 3D (isso mudou, o git de julho já ativou o suporte a 3D dos chipsets 200m, mas teremos de esperar um pouco mais para usá-la). A minha experiência com o XGL (que é vasta já que o uso desde a época do edgy e compiz 0.bolinha, e depois beryl e agora compiz fusion), é de que ele é bastante estável para java, vídeo (basta usar o X11 como saída ao invés do Xv, já que o X11 sobre o Xgl tb é acelerado), wine, vmware, virtualbox.
    MAS e friso no MAS, em alguns jogos wine e openGL ele pode realmente morrer e voltar pro gdm/kdm, então o meu conselho é: desktop de todos os dias com vídeos, aplicativos wine, java, etc? OK, extremamente estável. Jogos 3D? faça como eu, crie um segundo usuário com o xgl desativado (pode inclusive rodar ao mesmo tempo, funciona perfeitamente) e pronto.

  5. Yashá Gallazzi says:

    Olá amigo Padoca.

    Estou pedindo um pouco de socorro, pois sou novo no ubuntu e estou sofrendo muito pra instalar o compiz no meu note Acer 3050 1733 com placa ATI Radeon 1100.

    Já li infinitos tutoriais na net e uma das respostas do google me trouxe a esse post.

    Pelo que eu li, vc tem uma máquina semelhante à minha e conseguiu. Se puder me ajudar estarei muito grato.

    Como disse, sou novo no linux e ainda tenho algumas dúvidas que podem ser consideradas primárias, mas que me atrapalham bastante.

    Por exemplo, pelo que entendi, de acordo com seu tutorial acima, eu tenho que instalar os drivers proprietários mesmo da ATI, certo?

    Mas assim a tal da extensão composite não vai funcionar, não é? Mesmo assim eu consigo instalar o compiz depois?

    Por favor, me dê uma luz.

  6. Pingback: Instalando a driver proprietária da AMD/ATI num ACER 5102 com a ati XPress 1100 com (k)ubuntu. « Padoca Virtual

  7. padoca says:

    Veja meu último post, deve resolver o seu problema.

    Abraço.

  8. Rafael Almeida says:

    Olá uso o Ubuntu ;D
    instalei prefeitamente a placa ati
    dê uma olhada no resultado:
    glxinfo | grep direct
    direct rendering: Yes
    Instalei conforme o tutorial mais recebo a seguinte msg:
    Fatal: Failed test: texture_from_pixmap support
    Checks indicate that it’s impossible to start compiz on your system.

    como poderia me ajudar a resolver meu problema.

  9. Rafael Almeida says:

    ATENÇÃO ESSSE É O MEU ARQUIVO

    # /etc/X11/xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf(5) manual page.
    # (Type “man xorg.conf” at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg
    #rafael
    #Section Extensions
    #Option Composite 0
    #EndSection

    Section “ServerLayout”
    Identifier “Default Layout”
    Screen 0 “aticonfig-Screen[0]” 0 0
    InputDevice “Generic Keyboard”
    InputDevice “Configured Mouse”
    InputDevice “stylus” “SendCoreEvents”
    InputDevice “cursor” “SendCoreEvents”
    InputDevice “eraser” “SendCoreEvents”
    InputDevice “Synaptics Touchpad”
    EndSection

    Section “Files”

    # path to defoma fonts
    FontPath “/usr/share/fonts/X11/misc”
    FontPath “/usr/share/fonts/X11/cyrillic”
    FontPath “/usr/share/fonts/X11/100dpi/:unscaled”
    FontPath “/usr/share/fonts/X11/75dpi/:unscaled”
    FontPath “/usr/share/fonts/X11/Type1”
    FontPath “/usr/share/fonts/X11/100dpi”
    FontPath “/usr/share/fonts/X11/75dpi”
    FontPath “/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType”
    EndSection

    Section “Module”
    Load “i2c”
    Load “bitmap”
    Load “ddc”
    Load “dri”
    Load “extmod”
    Load “freetype”
    Load “glx”
    Load “int10”
    Load “vbe”
    EndSection

    Section “InputDevice”
    Identifier “Generic Keyboard”
    Driver “kbd”
    Option “CoreKeyboard”
    Option “XkbRules” “xorg”
    Option “XkbModel” “pc105”
    Option “XkbLayout” “us”
    Option “XkbVariant” “intl”
    EndSection

    Section “InputDevice”
    Identifier “Configured Mouse”
    Driver “mouse”
    Option “CorePointer”
    Option “Device” “/dev/input/mice”
    Option “Protocol” “ImPS/2”
    Option “ZAxisMapping” “4 5”
    Option “Emulate3Buttons” “true”
    EndSection

    Section “InputDevice”
    Identifier “Synaptics Touchpad”
    Driver “synaptics”
    Option “SendCoreEvents” “true”
    Option “Device” “/dev/psaux”
    Option “Protocol” “auto-dev”
    Option “HorizScrollDelta” “0”
    EndSection

    Section “InputDevice”
    Identifier “stylus”
    Driver “wacom”
    Option “Device” “/dev/input/wacom”
    Option “Type” “stylus”
    Option “ForceDevice” “ISDV4” # Tablet PC ONLY
    EndSection

    Section “InputDevice”
    Identifier “eraser”
    Driver “wacom”
    Option “Device” “/dev/input/wacom”
    Option “Type” “eraser”
    Option “ForceDevice” “ISDV4” # Tablet PC ONLY
    EndSection

    Section “InputDevice”
    Identifier “cursor”
    Driver “wacom”
    Option “Device” “/dev/input/wacom”
    Option “Type” “cursor”
    Option “ForceDevice” “ISDV4” # Tablet PC ONLY
    EndSection

    Section “Monitor”
    Identifier “Monitor Genérico”
    Option “DPMS”
    EndSection

    Section “Monitor”
    Identifier “aticonfig-Monitor[0]”
    Option “VendorName” “ATI Proprietary Driver”
    Option “ModelName” “Generic Autodetecting Monitor”
    Option “DPMS” “true”
    EndSection

    Section “Device”
    Identifier “ATI Technologies Inc RS485 [Radeon Xpress 1100 IGP]”
    Driver “ati”
    BusID “PCI:1:5:0”
    EndSection

    Section “Device”
    Identifier “aticonfig-Device[0]”
    Driver “fglrx”
    EndSection

    Section “Screen”
    Identifier “Default Screen”
    Device “ATI Technologies Inc RS485 [Radeon Xpress 1100 IGP]”
    Monitor “Monitor Genérico”
    DefaultDepth 24
    SubSection “Display”
    Depth 1
    Modes “1280×800”
    EndSubSection
    SubSection “Display”
    Depth 4
    Modes “1280×800”
    EndSubSection
    SubSection “Display”
    Depth 8
    Modes “1280×800”
    EndSubSection
    SubSection “Display”
    Depth 15
    Modes “1280×800”
    EndSubSection
    SubSection “Display”
    Depth 16
    Modes “1280×800”
    EndSubSection
    SubSection “Display”
    Depth 24
    Modes “1280×800”
    EndSubSection
    EndSection

    Section “Screen”
    Identifier “aticonfig-Screen[0]”
    Device “aticonfig-Device[0]”
    Monitor “aticonfig-Monitor[0]”
    DefaultDepth 24
    SubSection “Display”
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    Section “DRI”
    Mode 0666
    EndSection

    Section “Extensions”
    Option “Composite” “Enable”
    EndSection

  10. padoca says:

    Rafael, vc não leu o meu artigo com atenção.
    No xorg.conf é Option “Composite” “0” OU Option “Composite” “Disable”
    Altere e tente novamente, deve resolver🙂

    Abraço

  11. Paulo Cesar says:

    hehe digamos q eu comecei no Xgl antes de você então, pq eu comecei a usar em março de 2006, antes do dapper, e na época java, vídeo e várias coisas ficavam bem ruins. Depois disso eu acabei ficando um bom tempo sem usar, pq comecei a usar o hackintosh (nada ético mas blz.. eu gosto de coisas bonitas)

    Recentemente eu usei o fusion com o driver open source, que funciona bem aqui (9600pro), só q é bem mais lento que o oficial, e não roda direito o Frets on Fire, por isso perguntei da estabilidade do Xgl

    Vou testar então para ver como está, vlw

  12. Rafael Almeida says:

    Mais como vc vê no meu xorg que mostrei está lá abilitado.dá uma olhada.
    VLW!!!!

  13. Yashá Gallazzi says:

    Padoca,
    Primeiro obrigado pela ajuda. Graças às suas dicas consegui instalar o compiz no meu note com placa ATI Radeon Xpress 1100.
    Muito obrigado mesmo.
    Queria abusar um pouco mais dos seus conhecimentos.
    É o seguinte, notei que alguns efeitos visuais estão funcionando normalmente. São eles: as janelas tremendo, um pouco transparentes, efeitos ao minimizar e maximizar e o recurso do Alt+Tab.
    Porém outros não, como o desktop em 3D. Não consegui ver o tal do cubo, por exemplo. Também não consegui arrastar as janelas com o mouse. Aliás, não consigo pegar as janelas com o mouse pela barra superior.
    Alguma idéia?

  14. padoca says:

    hmm, vc precisa configurar esses plugins usando o configurador gráfico que fica em settings -> compiz config settings manager.

    Enjoy!

  15. Yashá Gallazzi says:

    Padoca,

    Foi o que pensei e por isso já tinha tentado.

    Na verdade, marquei como selecionados quase todos aqueles plugins, por via das dúvidas.

    Será que é isso que dá problema? Será que alguns plugins são incompatíveis com outros, de modo que eu só posso usar alguns deles?

    Outra coisa, li um outro tuto seu sobre instalar o beryl. Dá pra instalar ele já tendo esse compiz, ou são incompatíveis entre si?

  16. padoca says:

    Yashá, alguns plugins são sim, incompatíveis entre si, por exemplo, o desktop tube é incompatível com o desktop wall e o desktop plane, se vc tiver algum desses ativado, não poderá usar o cubo 3d. O configurador deveria avisar quando vc ativa um plugin que é incompatível com o outro.
    Em relaçãp ao beryl, para isso vc precisa saber um pouco da história. O compiz foi o primeiro a ser desenvolvido, e devido a rixas internas entre os desenvolvedores que estavam descontentes com algumas coisas, foi feita uma divisão (fork), e surgiu o beryl, só que ambos compartilhavam boa parte do código, o que era um desperdício enorme de recursos. Finalmente o ppl do compiz recuperou o juízo e concordou em serem mais flexíveis, fazendo com o código do beryl fosse reabsorvido (merge) de volta no código do compiz, gerando o compiz fusion que é uma mescla dos dois códigos. Vc pode instalar o beryl OU o compiz fusion, mas não vale mais a pena instalar o primeiro, visto que o compiz fusion tem tudo que o primeiro tinha e o beryl não é mais ativamente desenvolvido.

    Abraço

  17. Yashá Gallazzi says:

    Certo, eu tinha pensado mesmo que deveria ter alguma incompatibilidade entre os plugins.

    Olha só, uma vez instalado o compiz, eu consigo acionar os plugins só apertando neles dentro do compiz config settings manager, ou isso só serve para selecioná-los mas depois eles tem que ser baixados da net?

    Tento me explicar melhor: Os plugins já estão no computador prontos pra serem usados, ou cada um tem que ser baixado?

    Como eu posso restaurar as configurações originais do compiz? Deixar ele da maneira como ele estava quando o instalei no note, pra recomeçar a adicionar os plugins do zero?

    Sempre aproveito pra agradecer suas dicas.

    Está ajudando demais.

  18. padoca says:

    Yashá, sim, os plugins são instalados e atualizados através do apt-get, se eles aparecem no seu configurador é pq já estao instalados.
    Em teoria é pro configurador ativá-los no momento do clique, mas pode acontecer muito raramente que eles só são ativados se vc reiniciar o compiz.
    Para deixar tudo zerado, vc deve apagar o .compizconfig (diretório), que fica no seu /home/.

    Abraço.

  19. Yashá Gallazzi says:

    Pô desculpa de encher a paciência, mas pra alguém que está começando agora, surgem dúvidas que podem parecer tolas para os mais experientes.

    Por exemplo, se eu apagar o .compizconfig (diretório), que fica no /home/, eu vou estar apenas restaurando as configurações originais do compiz, ou vou estar desinstalando ele?

  20. padoca says:

    Yashá, não, tudo bem🙂
    No linux, o sistema, pacotes, etc, são instalados nos diretórios de sistema (crua condensação do funcionamento do sistema), já os de configuração ficam normalmente no seu sistema /home. Respondendo à sua pergunta, se vc apagar o .compizconfig, vc só estará apagando a SUA configuração, não o sistema em si🙂 e sem medo, quando vc chamar o configurador de novo, ele recria automaticamente o diretório apagado, mas com as configurações padrão.

    Abraço.

  21. Yashá Gallazzi says:

    Poxa tô apanhando mais do que gostaria.

    Tentei marcar apenas os plugins que tem referência ao cubo no desktop, mas nada.

    Não consigo habilitar esse efeito.

    Como a sua placa de vídeo é igual à minha, pensei em perguntar se na sua máquina funciona normalmente esse efeito?

    Se sim, poderia me dizer quais os plugins que vc tem acionados pra isso?

  22. padoca says:

    Yashá, não sei o que pode estar errado na sua configuração, já que aqui tudo funciona. Sugiro talvez reinstalar o compiz fusion? Se alguns efeitos funcionam, todos deveriam funcionar.

    Abraço

  23. ddo says:

    Valeu pela dica, mas aqui funcionou em parte.
    Primeiro, tive que colocar o xgl.desktop em /usr/share/xsessions/ . Escolhi a seção xgl e abriu o gnome!! não entendi o porque, mas o compiz funcionou. Ai fui fechar a seção para sair do gnome e para minha surpresa, abriu o kde!! hehe
    O que acha que pode ser?

  24. Yashá Gallazzi says:

    Caro Padoca,

    Depois de alguns testes e configurações que nem eu sei direito quais são, o compiz tá rodando legal, com direito a cubo 3D e tudo.

    Meus sinceros agradecimentos ao seu tuto.

    Como ambição pouca é bobagem, queria saber se é com o compiz ou com o beryl que conseguimos aqueles efeitos de pingos de água, neve e fechar as janelas pegando fogo.

    Se for com o beryl, sabe me dizer se é possível instalar ele na minha placa de vídeo (igual à sua)?

    Além disso, queria saber se é compatível com o compiz.

    Obrigado.

  25. padoca says:

    Yashá, como mencionei acima, o beryl não é mais desenvolvido, o compiz fusion é na realidade a fusão do compiz com o beryl e sim, o compiz fusion tem água, neve e janeas pegando fogo, tudo isso fica nos plugins que vc deve ter instalado no seu sistema, sugiro vc fuçar no configurador.

    um abraço

  26. Thiago Oliveira says:

    Olá padoca,

    Estou, como todos, com uma placa radeon xpress 1100.
    Os testes com os comandos glxinfo e fgl_glxgears passaram perfeitamente.
    Tenho o mesmo problema que o Rafael Almeida, mas ao contrário dele, eu entendi que a extensão composite tem que estar DESABILITADA😉
    pois assim está.
    Mesmo assim o problema persiste. Pelo que eu pesquisei, o problema deve mesmo ser na configuração do xorg.conf.
    Alguma idéia? Vc poderia disponibilizar o seu xorg.conf?

    A sessão do driver no xorg está assim:
    Section “Device”
    Identifier “ATI Technologies Inc RS485 [Radeon Xpress 1100 IGP]”
    Driver “fglrx”
    Option “VideoOverlay” “on”
    Option “OpenGLOverlay” “off”
    Busid “PCI:1:5:0”
    EndSection

    Obrigado!!

  27. Jorge says:

    Bom dia. Vou tentar explicar: Tenho um NOTE ACER, com placa ATI Radeon Xpress 1100. Tem algum driver para instalar e conseguir rodar o Second Life? Como?
    Obrigado

  28. padoca says:

    Jorge, assim fica dificil. Se vc já tem o suporte a 3D funcionando, é so rodar o second life sem mais complicações. Se vc estiver rodando o compiz, ai já é outra historia, vc precisa escrever:

    LD_PRELOAD=/usr/lib/fglrx/libGL.so.1.2.xlibmesa secondlife

    Boa sorte

  29. Khristian says:

    Opa
    Tenho esse mesmo notebook, mas usando gnome (o kde aqui dava erro de vez em quando, ainda não sei pq).
    Segui seu tutorial, ele instalou tudo direitinho. Você poderia adicionar a chave do repositório do Treviño ao tut, usando o comando KEY=DD800CD9; gpg --keyserver subkeys.pgp.net --recv $KEY && gpg --export --armor $KEY | sudo apt-key add - tirado de http://www.compiz.org/Compiz_and_Copmiz_Fusion_GIT_Ubuntu_Repository.

    Mas o meu problema é o seguinte: eu inicio o compiz com compiz --replace -c metacity, e ele retorna direto ao metacity depois de aplicar brevemente o compiz (com decoraçÕes de janela). Se eu executar compiz --replace metacity (note que eu tirei o -c), ele retira a decoração das janelas, mas funciona lindamente (wobbly windows, transparência, e tudo mais). Mesmo usando o emerald como decorador ele some com as decorações. Tens alguma idéia de como resolver isso?
    Valeu,
    Khristian

  30. Khristian says:

    Deixa quieto, funcionou agora😛
    Outra sugestão, podes pegar a parte do fusion-icon do tutorial do hamacker em http://hamacker.wordpress.com/2007/06/21/compiz-fusion-no-ubuntu-feisty/ . Instalei aqui e funciona bem, além de ser útil.

  31. Olá Padoca,

    Tenho um ACER 5050-3233 que tem como placa de vídeo a ATI XPress 200M. Segui suas instruções à risca e tive o mesmo erro reportado pelos amigos Rafael e Thiago Oliveira (o compiz reporta que não é possível rodar com, dando o seguinte output: Fatal: Failed test: texture_from_pixmap support
    Checks indicate that it’s impossible to start compiz on your system.)

    Segue o meu xorg.conf para que se possível, me dê um feedback:

    ===

    # /etc/X11/xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf(5) manual page.
    # (Type “man xorg.conf” at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section “ServerLayout”
    Identifier “Default Layout”
    Screen “Default Screen” 0 0
    InputDevice “Generic Keyboard”
    InputDevice “Configured Mouse”
    InputDevice “stylus” “SendCoreEvents”
    InputDevice “cursor” “SendCoreEvents”
    InputDevice “eraser” “SendCoreEvents”
    EndSection

    Section “Files”

    # path to defoma fonts
    FontPath “/usr/share/fonts/X11/misc”
    FontPath “/usr/share/fonts/X11/cyrillic”
    FontPath “/usr/share/fonts/X11/100dpi/:unscaled”
    FontPath “/usr/share/fonts/X11/75dpi/:unscaled”
    FontPath “/usr/share/fonts/X11/Type1”
    FontPath “/usr/share/fonts/X11/100dpi”
    FontPath “/usr/share/fonts/X11/75dpi”
    FontPath “/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType”
    EndSection

    Section “Module”
    Load “i2c”
    Load “bitmap”
    Load “ddc”
    Load “dri”
    Load “extmod”
    Load “freetype”
    Load “glx”
    Load “int10”
    Load “vbe”
    EndSection

    Section “ServerFlags”
    Option “AIGLX” “off”
    EndSection

    Section “InputDevice”
    Identifier “Generic Keyboard”
    Driver “kbd”
    Option “CoreKeyboard”
    Option “XkbRules” “xorg”
    Option “XkbModel” “abnt2”
    Option “XkbLayout” “br”
    EndSection

    Section “InputDevice”
    Identifier “Configured Mouse”
    Driver “mouse”
    Option “CorePointer”
    Option “Device” “/dev/input/mice”
    Option “Protocol” “ImPS/2”
    Option “ZAxisMapping” “4 5”
    Option “Emulate3Buttons” “true”
    EndSection

    Section “InputDevice”
    Identifier “stylus”
    Driver “wacom”
    Option “Device” “/dev/input/wacom”
    Option “Type” “stylus”
    Option “ForceDevice” “ISDV4” # Tablet PC ONLY
    EndSection

    Section “InputDevice”
    Identifier “eraser”
    Driver “wacom”
    Option “Device” “/dev/input/wacom”
    Option “Type” “eraser”
    Option “ForceDevice” “ISDV4” # Tablet PC ONLY
    EndSection

    Section “InputDevice”
    Identifier “cursor”
    Driver “wacom”
    Option “Device” “/dev/input/wacom”
    Option “Type” “cursor”
    Option “ForceDevice” “ISDV4” # Tablet PC ONLY
    EndSection

    Section “Monitor”
    Identifier “Generic Monitor”
    HorizSync 28.0 – 64.0
    VertRefresh 43.0 – 60.0
    Option “DPMS”
    EndSection

    Section “Device”
    Identifier “ATI Technologies Inc RS485 [Radeon Xpress 1100 IGP]”
    Driver “fglrx”
    Option “VideoOverlay” “on”
    Option “OpenGLOverlay” “off”
    BusID “PCI:1:5:0”
    EndSection

    Section “Screen”
    Identifier “Default Screen”
    Device “ATI Technologies Inc RS485 [Radeon Xpress 1100 IGP]”
    Monitor “Generic Monitor”
    DefaultDepth 24
    SubSection “Display”
    Depth 1
    Modes “1280×800”
    EndSubSection
    SubSection “Display”
    Depth 4
    Modes “1280×800”
    EndSubSection
    SubSection “Display”
    Depth 8
    Modes “1280×800”
    EndSubSection
    SubSection “Display”
    Depth 15
    Modes “1280×800”
    EndSubSection
    SubSection “Display”
    Depth 16
    Modes “1280×800”
    EndSubSection
    SubSection “Display”
    Depth 24
    Modes “1280×800”
    EndSubSection
    EndSection

    Section “DRI”
    Mode 0666
    EndSection

    Section “Extensions”
    Option “Composite” “Disable”
    EndSection
    ===

    Abraços e obrigado de antemão…

  32. padoca says:

    Rafael, tiago e yuri, aparentemente o xorg.conf está correto, mas somente por ele é difícil saber o que se passa. Rafael, você poderia postar o seu /var/log/Xorg.0.log. Ele poderá mostrar mais informações relevantes (por exemplo se o suporte a 3D da driver foi ativado e se não, porquê).

    Abraço.

  33. Rodrigo says:

    Humm, pra usuários de Nvidia tem alguma alteração?

  34. padoca says:

    Rodrigo, pra nvidia muda bastante coisa sim. Inclusive o xorg.conf precisa de alterações diversas das necessárias para ATi. Aconselho-o a procurar um tutorial especifico para nvidia.

    abraço.

  35. Pedro says:

    ola padoca, primeiramente gostaria de agradecer por esse tutorial🙂
    mas estou tendo o mesmo problema que alguns:
    Fatal: Failed test: texture_from_pixmap support

    uso uma placa Radeon 9800 Pro e ateh onde consegui descobrir a placa esta corretamente instalada
    também ja desativei a extencao composit no xorg.conf.

    a seguir uma copia do meu Xorg.0.log
    http://docs.google.com/View?docid=dcq6snp9_5hrhjnb

    agradeco qualquer ajuda

  36. padoca says:

    Pedro (35.), vi seu Xorg.log, e aparentemente está tudo funcionando corretamente, o suporte a 3D é inicializado corretamente, ou seja, nao é a driver, sugiro que rode o compiz –replace na linha de comando depois de subir o kde, e veja que erro está sendo retornado. Não se esqueça que vc precisa subir o kde via XGL como está explanado no meu blog, e não chamar o compiz diretamente, ou seja, vc precisa ter a entrada de Xgl no KDM/GDM. Creio que esse possa ser o seu problema, faltou esse passo.

    Um abraço.

  37. Pedro says:

    Obrigado padoca era esse mesmo o problema.
    porem nao estou conseguindo logar pela sessao usando o XGL.
    a tela fica preta e apos 1 ou 2 segundos retorna para a tela de login.
    em todo caso obrigado pela ajuda!

  38. Patrick says:

    aff q coisa babaca …
    da um trabalhao pra uma coisa tao simples !
    vc tem q ter mto tempo de sobra pra fica nessa inrolacao …

    ——————
    pq ate agora nenhum troxa nao criou um .deb disso ?
    facilitaria a vida de todos.

  39. Bruno IKE says:

    to com o mesmo problema do #37,

    eu logo, ele fica 2 segundos na tela tipo logando e retorna pra tela inicial do login…

    meu aticonfig –initial retorna

    Found fglrx primary device section
    Nothing to do, terminating.

  40. news says:

    Is it okay to place a portion of this on my weblog if I publish a reference to this website?

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s